MusE Sequencer forum

Full Version: problem with qtcreator building muse.pro
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

I want to try to find the bug with the zynaddsynth.
When I remember right,
the last Time, I had trapped the bug
somewhere in ZynAddSynth with missing initialisation of the dynamic linked object file.

For now....
I tried building the Muse2 project with qtcreator.

From CMakeLists,txt I got it compiled.

But when I try to buld it from muse.pro (inside qtcreator)
The first SOURCE file ./al/dspSSE.cpp \

============================= muse.pro

SOURCES = \
./al/dspSSE.cpp \
./al/dspXMM.cpp \
./al/al.cpp \
./al/dsp.cpp \
./muse/sig.cpp \
./muse/seqmsg.cpp
[...]
=======================
it runs into an assembler code
Do I need a special Compiler flag in the muse.pro file?
------------------------------------------./al/dspSSE.cpp \
#; void x86_sse_mix_buffers_with_gain (float *dst, float *src, long nframes, float gain);

.globl x86_sse_mix_buffers_with_gain
.type x86_sse_mix_buffers_with_gain,@function

x86_sse_mix_buffers_with_gain:
#; 8(%ebp) = float *dst = %edi
#; 12(%ebp) = float *src = %esi
#; 16(%ebp) = long nframes = %ecx
#; 20(%ebp) = float gain = st(0)

-------------------------------------------

Yours,
willy <!-- sBig Grin --><img src="{SMILIES_PATH}/icon_e_biggrin.gif" alt="Big Grin" title="Very Happy" /><!-- sBig Grin -->
Hi Willy!

I'm very sorry but the .pro file isn't supported, infact I will move it to an not_used directory right away.
I guess it is possible to fix it but better would be to get CMake build working.

It should be possible to import the CMakeLists.txt in qtcreator, I think we have talked about this before but I forget what the problem was.
What version of qtcreator do you have installed?

Regards,
Robert