MusE Sequencer forum

Full Version: Python support will not be built
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello <!-- sBig Grin --><img src="{SMILIES_PATH}/icon_e_biggrin.gif" alt="Big Grin" title="Very Happy" /><!-- sBig Grin -->

I am trying to get MuSe going on my system. I can't use Muse1.1 because I have qt4 not 3, and, besides, newer is better, right? So I have tried using the latest beta from the website, and also from svn, but both give me the same error:

The following modules will not be built: Python support VST support Experimental features

I was able to get it to build without Python support, but when I ran the program there was a big empty white square over top of the main window (which otherwise looked very nice!). Unfortunately, this white square made the program unusable. I'm hoping that getting the Python module to build will fix that problem, whatever it is.

I'm running Python 2.6.6, and I don't know why it's not being recognized by the build scripts.

If anyonw could give me some help to get this to work, I would appreciate it.

Thanks,

Gary Millard
Hi, sorry for late reply.
Mm, you say you have a big empty white square covering things?
Whew, that's odd. Perhaps that 'post-it' note you left on the screen? He he...

Nope, I don't think Python has anything to do with it.
I wouldn't worry about that setting for now.
I think there was a bit of a mixup in the python enabling detection recently,
but I think it is built anyway - it seems to work here.

The only thing I can think of, lacking details (tell more: what distro etc?), is that
on Dec 17, 2011 in the release_2_0 SVN branch I fixed a similar issue:
- Fixed long-time graphics corruption issue: Large areas of desktop erased to background.

This had to do with popup menu 'ghosts', left behind when the popup closed.
But that bug never made it unusable, just occasional non-updating graphics.

So tell us more. Any luck yet? Screenshot would help.

Thanks. Tim.