MusE Sequencer forum

Full Version: How to connect external keyboard?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Ok. I have bought a Korg Microkey USB MIDI keyboard. I installed qjackctl and the microkey shows up under setup->settings->input device->hw:1 Korg Microkey. I set the microkey as the input, set the output soundcard and restart jack. But the keyboard does nothing in Muse (Under the input icon of the softsynth: Warning: No input devices). The playback works fine. Perhaps I don't know what I'm doing, and that's probably right, but that's the reason why I am here <!-- sWink --><img src="{SMILIES_PATH}/icon_e_wink.gif" alt="Wink" title="Wink" /><!-- sWink --> How do I connect the Korg Microkey to Muse? The vendor told me that the keyboard adheres to the USB-MIDI-standard...
I think it is highly unlikely that your keyboard does not conform to the USB midi standard. You can check if you system detects it with the "lsusb" and "amidi -l" commands. Also, it should appear in the "ALSA" tab of QJackCtl. To test if it works independently of Muse, connect (using QJackCtl) the output of your keyboard so some softsynth like Yoshimi or perhaps a virtual keyboard (e.g. VMPK) and check if you get a sound (or see the keys move on VMPK). For connecting to Muse, see my post <!-- l --><a class="postlink-local" href="https://sourceforge.net/apps/phpbb/lmuse/viewtopic.php?f=1&t=112&p=283#p283">viewtopic.php?f=1&t=112&p=283#p283</a><!-- l -->.
Thanks ediehl! The 'lsusb' and 'amidi -l' both show the Korg. VMPK though does not respond to pressing keys on my Korg. qjackctl displays the Korg as hw:0 (set as input). No response.
Hi again. I am a beginner with linux. I have retried with de KORG microkey and the newest version of MusE. Being a rookie, I still don´t understand many of the actions required to make MusE sing. When I invoke lsusb or amidi -l the microkey shows up nicely. But I don´t understand what is required to make things work (apart from some knowledge on my side <!-- sWink --><img src="{SMILIES_PATH}/icon_e_wink.gif" alt="Wink" title="Wink" /><!-- sWink --> ). Do I have to install ALSA or QJackCtl separately from MusE to get de microkey working? What settings do I have te make?

Many thanks <!-- sBig Grin --><img src="{SMILIES_PATH}/icon_e_biggrin.gif" alt="Big Grin" title="Very Happy" /><!-- sBig Grin -->
papoy Wrote:Hi again. I am a beginner with linux. I have retried with de KORG microkey and the newest version of MusE. Being a rookie, I still don´t understand many of the actions required to make MusE sing. When I invoke lsusb or amidi -l the microkey shows up nicely. But I don´t understand what is required to make things work (apart from some knowledge on my side <!-- sWink --><img src="{SMILIES_PATH}/icon_e_wink.gif" alt="Wink" title="Wink" /><!-- sWink --> ). Do I have to install ALSA or QJackCtl separately from MusE to get de microkey working? What settings do I have te make?

Many thanks <!-- sBig Grin --><img src="{SMILIES_PATH}/icon_e_biggrin.gif" alt="Big Grin" title="Very Happy" /><!-- sBig Grin -->

Hi papoy!

lsusb and amidi are good to find out if the devices show up correctly in your system. It sounds like it indeed shows up fine.
There are two ways forward.
Start jackd with the extra argument -X seq. MusE defaults to showing only midi devices through jack and this enables jack to see the midi device through alsa-sequencer.
The other way is to start MusE with -A argument, which enables MusE to see the alsa-sequencer devices directly.

Let me know if that doesn't help!

Regards,
Robert
When I do both of these, the microkey shows op in the MusE midi-dialog. The red indicator in the sidebar lights up when I press a key on the microkey. There is no sound when I play the keyboad though. I subsequently made an instance of fluid_synth with GM soundfont in the midi-dialog. I dont understand how to attach fluid_synth to the keyboard as to hear it play though.

The microkey is on port 1 and channel 1.
Fluid_synth is op port 3 and channel 2.
(What does it mean?)
Hi Papoy,

papoy Wrote:When I do both of these, the microkey shows op in the MusE midi-dialog. The red indicator in the sidebar lights up when I press a key on the microkey. There is no sound when I play the keyboad though. I subsequently made an instance of fluid_synth with GM soundfont in the midi-dialog. I dont understand how to attach fluid_synth to the keyboard as to hear it play though.

The microkey is on port 1 and channel 1.
Fluid_synth is op port 3 and channel 2.
(What does it mean?)

I think what you are asking is mostly answered by the first tutorial here:
<!-- m --><a class="postlink" href="http://muse-sequencer.org/index.php/Tutorials">http://muse-sequencer.org/index.php/Tutorials</a><!-- m -->
I mean to do new tutorials as MusE does not work exactly the same today.

Basically what is needed is that the midi track needs midi-input (this part you have covered, there is midi recorded on the midi track) and midi-output, for this the soft synth should be chosen in the Port column and the rec button on the midi track should be clicked. When this is done, playing on the keyboard should result in sound coming out of the softsynth.

Hope that helps,
Robert