Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums

(Advanced Search)

Forum Statistics
» Members: 273
» Latest member: tammy33
» Forum threads: 115
» Forum posts: 536

Full Statistics

Online Users
There is currently 1 user online
» 0 Member(s) | 1 Guest(s)

Latest Threads
Writing help from essay w...
Forum: Getting Help
Last Post: tammy33
12-06-2017, 07:09 AM
» Replies: 0
» Views: 136
New Forum
Forum: Random Discussion
Last Post: Cyberops
12-06-2017, 06:48 AM
» Replies: 6
» Views: 6,380
congratulation to beta,
Forum: Random Discussion
Last Post: malangtravel
06-06-2016, 02:00 PM
» Replies: 5
» Views: 6,459
MusE-2.2.1 released
Forum: Getting Help
Last Post: malangtravel
06-06-2016, 01:57 PM
» Replies: 3
» Views: 8,391
copy parts
Forum: Getting Help
Last Post: spamatica
05-05-2016, 07:12 PM
» Replies: 4
» Views: 886
Compiling MusE with Stein...
Forum: Getting Help
Last Post: spamatica
04-18-2016, 07:56 PM
» Replies: 1
» Views: 436
LV2 GTK2 ui support is no...
Forum: Getting Help
Last Post: spamatica
03-25-2016, 10:37 AM
» Replies: 1
» Views: 665
VST connections lost afte...
Forum: Getting Help
Last Post: spamatica
03-23-2016, 08:05 PM
» Replies: 7
» Views: 1,918
Tempo Varies
Forum: Getting Help
Last Post: AndrewB53
02-13-2016, 04:34 PM
» Replies: 2
» Views: 1,190
Export to wav or mp3 the ...
Forum: Getting Help
Last Post: danvd
02-01-2016, 11:08 AM
» Replies: 1
» Views: 1,005

 
  song info is begging
Posted by: mane_groteks - 05-04-2011, 06:40 AM - Forum: Getting Help - Replies (4)

In Muse2
When a song is saved with text in the "song info" - next time when loading this song - the "song info" window pops up and is begging for confirmation.
song-loading stops until that.

Greetings,
mane

Print this item

  congratulation to beta,
Posted by: mane_grotesk - 05-03-2011, 11:48 AM - Forum: Random Discussion - Replies (5)

- good work! and thank you

greetings

Print this item

  The name 'gridLayout' (QGridLayout) is already in use
Posted by: willyfoobar - 04-28-2011, 01:11 PM - Forum: Getting Help - Replies (1)

Hi folks,

I compiled the muse2 branch.
I used the CMakeLists.txt for creating the projekt.
There seems to be a problem with a a layout file (gensetbase.ui)

/home/wallee/hafi/Dokumente/prj/musik/muse/muse2-unstable/muse/widgets/gensetbase.ui: Warning: The name 'gridLayout' (QGridLayout) is already in use, defaulting to 'gridLayout9'.

I don't know how to fix it
Somebody else should fix this.


Bye,
- Willy

Print this item

  suggest parentheses around ‘&&’ within ‘||’
Posted by: willyfoobar - 04-28-2011, 01:05 PM - Forum: Getting Help - Replies (1)

Hi folks.

when I compile muse2,
i get these compiler warnings:

/home/wallee/hafi/Dokumente/prj/musik/muse/muse2-unstable/muse/master/lmaster.cpp: In member function ‘void LMaster::updateList()’:
/home/wallee/hafi/Dokumente/prj/musik/muse/muse2-unstable/muse/master/lmaster.cpp:296:78: warning: suggest parentheses around ‘&&’ within ‘||’
/home/wallee/hafi/Dokumente/prj/musik/muse/muse2-unstable/muse/master/lmaster.cpp:301:78: warning: suggest parentheses around ‘&&’ within ‘||’
/home/wallee/hafi/Dokumente/prj/musik/muse/muse2-unstable/muse/master/lmaster.cpp:307:78: warning: suggest parentheses around ‘&&’ within ‘||


======================== In my eyes theer should be added like here parantheses
if ( ( /*here*/ (ik != k->rend()) && (is == s->rend()) && (ik->second.tick >= it->second->tick) /*upto here*/ )
|| (/*here*/ (it == t->rend()) && (ik->second.tick >= is->second->tick ) /*upto here*/) ) {// ik biggest
insertKey(ik->second);
++ik;
}

Bye,
WillyFoobar <!-- sBig Grin --><img src="{SMILIES_PATH}/icon_e_biggrin.gif" alt="Big Grin" title="Very Happy" /><!-- sBig Grin -->

Print this item

  MusE and Jack-MIDI
Posted by: Troubadix - 04-28-2011, 12:02 PM - Forum: Getting Help - Replies (7)

Hi,

as on this page seem to respond the professionals, I answer my question here too. <!-- sWink --><img src="{SMILIES_PATH}/icon_e_wink.gif" alt="Wink" title="Wink" /><!-- sWink -->

It´s that I got problems with my ALSA-MIDI connections. If I use them, they make a cracking noise. So I would like to connect MusE just in Jack-MIDI. But I´m not able to do that, neither with a2jmidid. a2j creates in Jack (Jack-MIDI) a port called "MusE sequenzer [130] (playback): MusE Port 0". But in MusE in the settings in Midi-ports doesn´t appear that.

So I´m not able to send MIDI to MusE via Jack-MIDI, nor am I able to get MIDI from MusE and send it to an instrument via Jack-MIDI. In ALSA-MIDI I may do that, but as I say, I got some troubles with ALSA-MIDI (not just using MusE, also with other programs), wich I don´t have with Jack-MIDI.

On the main page of MusE (muse-sequencer.org) is written, that MusE supports Jack-MIDI. That means, that it should work even without a2jmidid, rigt? How could I do that?

Thanks and greets, Nils.

Print this item

  problem with qtcreator building muse.pro
Posted by: willyfoobar - 04-27-2011, 05:04 PM - Forum: Getting Help - Replies (1)

Hello,

I want to try to find the bug with the zynaddsynth.
When I remember right,
the last Time, I had trapped the bug
somewhere in ZynAddSynth with missing initialisation of the dynamic linked object file.

For now....
I tried building the Muse2 project with qtcreator.

From CMakeLists,txt I got it compiled.

But when I try to buld it from muse.pro (inside qtcreator)
The first SOURCE file ./al/dspSSE.cpp \

============================= muse.pro

SOURCES = \
./al/dspSSE.cpp \
./al/dspXMM.cpp \
./al/al.cpp \
./al/dsp.cpp \
./muse/sig.cpp \
./muse/seqmsg.cpp
[...]
=======================
it runs into an assembler code
Do I need a special Compiler flag in the muse.pro file?
------------------------------------------./al/dspSSE.cpp \
#; void x86_sse_mix_buffers_with_gain (float *dst, float *src, long nframes, float gain);

.globl x86_sse_mix_buffers_with_gain
.type x86_sse_mix_buffers_with_gain,@function

x86_sse_mix_buffers_with_gain:
#; 8(%ebp) = float *dst = %edi
#; 12(%ebp) = float *src = %esi
#; 16(%ebp) = long nframes = %ecx
#; 20(%ebp) = float gain = st(0)

-------------------------------------------

Yours,
willy <!-- sBig Grin --><img src="{SMILIES_PATH}/icon_e_biggrin.gif" alt="Big Grin" title="Very Happy" /><!-- sBig Grin -->

Print this item

  EXECUTING muse2 stops on error
Posted by: WillyFoobar - 04-23-2011, 09:05 PM - Forum: Getting Help - Replies (5)

Hello,

I use a stanbdard OpenSuSE 11.4 Linux on a Intel 32 bit System
After compiling w.o. any problems,
I try to start muse2.

As I switch verbose mode in qjackctl
I receive these error messages:

===================
hafi@wallee:~/Dokumente/prj/PHYSIK/EAKUSTIK/JACK> muse2
Denormal protection enabled.
Jack: JackClient::SetupDriverSync driver sem in flush mode
Jack: JackPosixSemaphore::Connect jack_sem.500_default_MusE
Jack: Already connected name = MusE
Jack: Clock source : system clock via clock_gettime
Jack: JackLibClient::Open name = MusE refnum = 3
Jack: jack_set_graph_order_callback ext_client 81b3428 client 81b3428
Jack: SetGraphOrderCallback
Jack: jack_set_thread_init_callback ext_client 81b3428 client 81b3428
Speicherzugriffsfehler
===================

What is wrong???

Yours,
- Willy <!-- sBig Grin --><img src="{SMILIES_PATH}/icon_e_biggrin.gif" alt="Big Grin" title="Very Happy" /><!-- sBig Grin -->

Print this item

  muse2 compiles with only minor warnings
Posted by: WillyFoobar - 04-23-2011, 08:59 PM - Forum: Getting Help - No Replies

Compiling the release actually svn checkout
of lmuse2 gives only few relavant errors:

muse/mplugins/mitplugin.cpp:33:16: warning: ‘act’ may be used uninitialized in this function
muse/master/lmaster.cpp:296:78: warning: suggest parentheses around ‘&&’ within ‘||’

Yours,
- Willy <!-- sBig Grin --><img src="{SMILIES_PATH}/icon_e_biggrin.gif" alt="Big Grin" title="Very Happy" /><!-- sBig Grin -->

Print this item

  muse2 compiles with only minor warnings
Posted by: WillyFoobar - 04-23-2011, 08:58 PM - Forum: Getting Help - Replies (1)

Compiling the release actually svn checkout
of lmuse2 gives only few relavant errors:

muse/mplugins/mitplugin.cpp:33:16: warning: ‘act’ may be used uninitialized in this function
muse/master/lmaster.cpp:296:78: warning: suggest parentheses around ‘&&’ within ‘||’

Yours,
- Willy <!-- sBig Grin --><img src="{SMILIES_PATH}/icon_e_biggrin.gif" alt="Big Grin" title="Very Happy" /><!-- sBig Grin -->

Print this item

  muse2 compiles with only minor warnings
Posted by: WillyFoobar - 04-23-2011, 08:58 PM - Forum: Getting Help - No Replies

Compiling the release actually svn checkout
of lmuse2 gives only few relavant errors:

muse/mplugins/mitplugin.cpp:33:16: warning: ‘act’ may be used uninitialized in this function
muse/master/lmaster.cpp:296:78: warning: suggest parentheses around ‘&&’ within ‘||’

Yours,
- Willy <!-- sBig Grin --><img src="{SMILIES_PATH}/icon_e_biggrin.gif" alt="Big Grin" title="Very Happy" /><!-- sBig Grin -->

Print this item