Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Linux and Akai LPK25
#1
I'm fairly new to Muse so a novice error is a possibility.

I am using Fedora Jam (64 bit) and it is latest version.
Have un-installed and reinstalled Muse. Now on version version 2.1.2.

Jack is installed and functioning when I sue Hydrogen drum program.

I have followed the tutorial and managed to get sound out of Muse using the Vam soft synth using the mouse pointer on the keys.

I can not see anywhere where I can select the Akai LPK25.

With RoseGarden I can see the input meter moving as I tap the keyboard and and dots appear on the screen.
No sound comes out.
So I *think* that Linux has detected the keyboard and installed some drivers.

So I have sound generally, and something detect the keyboard.
Any suggestions?

Seen mention of portaudio and portmidi somewhere. These are installed.

Thanks in advance for any pointers, even if it is to the howto page I havn'e spotted yet.
Reply
#2
Hi,

Seems you are well on your way to getting it to work.

I guess if you look in the MusE Settings->Midi Ports / Soft synth dialog there is no midi device to configure.

The reason is likely that sometime ago we changed the default to only show jack midi devices, unfortunately jack doesn't show midi devices by default. I guess we were proactively trying to move people to using Midi through jack. This hasn't really paid off yet..
To enable midi in jack add the argument -Xseq after alsa argument, if you are starting jack through qjackctl there is probably an option to click.

It's possible to allow MusE to show the midi devices directly too, just start muse with the -A argument.
Usually no further configuration is needed. If you add a midi track there's a small indicator in the track info showing if there's input coming when you play on the keyboard.

Let me know if that helps!

Regards,
Robert
Reply
#3
Hi Robert

The -A switch works.
Thanks

When I add a MIDI track and view the mixer I can see the meter going up and down as I touch the keys.
I have even the got dots appearing on the track as I record at one point - can't remember how I got to this.

Still tinkering and looking around various places to figure out how to get sound.
If you or someone else can point to a definitive howto in the meantime I would be very appreciative.
Regards
Leigh
Reply
#4
slart1bartfast Wrote:Hi Robert

The -A switch works.
Thanks

When I add a MIDI track and view the mixer I can see the meter going up and down as I touch the keys.
I have even the got dots appearing on the track as I record at one point - can't remember how I got to this.

Still tinkering and looking around various places to figure out how to get sound.
If you or someone else can point to a definitive howto in the meantime I would be very appreciative.
Regards
Leigh

Hi Leigh,

Sorry for the less than perfect delay in answering...

Though in truth I don't think there is any definitive howto on this.. I have wanted to add more tutorials for a long time now, hopefully I'll get around to it soon.

If the meter goes up and down when you touch keys you basically got it working.
To record then you need the track rec-enabled, the red dot at the beginning of the track in the arranger, and the rec button in the toolbars enabled, pressing play now will start recording.

Regards,
Robert
Reply
#5
I think I must be making a basic mistake.

I have three 'tracks' configured: Input, MIDI track and output.
The mixer meter for the MIDI track goes up and down when I play the key board, but nothing happens on the input or output meters.

MIDI : source is all MIDI channels on Akai LPK25, target is input 1.
Input 1: source is all MIDI channels on Akai LPK25, target is output 1
Output 1: source is input 1, target is channel 1 --> system playback 1, & channel 2 --> system playback 2.

When I record I get little grey dots appearing on the track display, getting higher and lower is I press keys that are lower and higher up the scale.

I think I am nearly there, just not quite joining up the dots....

Thanks for your advice so far.
Reply
#6
Hi Leigh, sorry for the delay..
slart1bartfast Wrote:I think I must be making a basic mistake.

I have three 'tracks' configured: Input, MIDI track and output.
The mixer meter for the MIDI track goes up and down when I play the key board, but nothing happens on the input or output meters.
MIDI : source is all MIDI channels on Akai LPK25, target is input 1.
Input 1: source is all MIDI channels on Akai LPK25, target is output 1
Output 1: source is input 1, target is channel 1 --> system playback 1, & channel 2 --> system playback 2.

When I record I get little grey dots appearing on the track display, getting higher and lower is I press keys that are lower and higher up the scale.

You get the gray dots so your recording is infact working, what you are missing is likely a playback device.
As I understand the LPK25 does not produce sound, only midi, so you need a separate (soft) synth.

Easiest way to achieve this is to right click in the tracklist and add a Synth from the sub menu, for instance the VAM synth.
The output of the VAM synth should be connected to the Output 1. Set the [Port] column of the midi track to your soft synth and the midi track will send the notes to the soft synth which in turn hopefully will produce audible sound

Going forward, exchange the VAM synth for something more usable. A first (good) step is to try the FluidSynth, though it requires an extra step in loading a soundfont (SF2). Search for free soundfonts on the internet and you will get more than you can ever use.

Last, the Input 1 track is an audio track and should not be necessary in this scenario. The Output track is also an audio track but it is required if you use softsynths as they produce audio.

I hope I didn't leave anything out. I'd better start doing some updated videos soon <!-- sTongue --><img src="{SMILIES_PATH}/icon_razz.gif" alt="Tongue" title="Razz" /><!-- sTongue -->

/Robert
Reply
#7
Robert
Thanks for your update.
I do appreciate your time and patience with helping out.
Can I call on a bit more of your patience?

I now have Vam synth, midi track and output.
Vam-0: input = nothing selectable, ouput = Out 1
Midi: input = LPK25, output = soloing chain or Audio Returns (nothing selectable).
Out1: input = vam-0/Channel 1, output = channel 1 system playback.

As far as I can figure out I need to send Midi track to vam-0 somehow but I'm not getting an obvious option.
The Off/Read/Touch/Write options on vam-0 and Out1 are both set to Off. I ave played around with various combinations for these and it doesn't seem to do anything.

Thanks

Leigh
Reply
#8
Got it!
Random click-monkey method sometimes works.

Thanks.
Reply
#9
That sounds great!

In other news I'm gearing up for making some new videos to get more of the current workflow shown.

Regards,
Robert
Reply
#10
Easiest way in achieving this is usually to correct click on inside the tracklist and also convey a Synth in the sub-contract selection, as an illustration the particular VAM synth.
This output of the VAM synth must be connected to the particular End result 1. Established the particular [Port] column of the midi observe on your gentle synth as well as the midi observe may deliver the particular notes towards the gentle synth which preferably may produce audible appear ALONG WITH Randomly click-monkey procedure at times is effective.






______________________________________________________________________________________________
NoorAlamShahzad
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)